Basic Border Gateway Protocol

Một phần của tài liệu CCNP practical studies routing (Trang 244 - 251)

This chapter focuses on Border Gateway Protocol Version 4 (BGP4). BGP4 is covered only slightly in the CCNP routing examination. However, this chapter covers BGP4 in a little more detail to ensure that you have a good appreciation of the way networks connect to the Internet or in large organizations.

This chapter covers the basics of Border Gateway Protocol (BGP). Chapter 7,

“Advanced BGP,” covers more advanced BGP topics and scenarios. This chapter contains five practical scenarios to complete your understanding of basic BGP and to help you appreciate the complexity of BGP.

Basic Border Gateway Protocol (BGP4) Defined

The different versions of BGP range from 1–4; the industry standard is Version 4.

You can, however, configure BGP Versions 2, 3, and 4 on a Cisco IOS router. The default standard is BGP Version 4 and is referred to as BGP4.

BGP4 is defined in industry standard RFC 1771. BGP enables you to create an IP network free of routing loops among different autonomous systems. An AS is a set of routers under the same administrative control.

BGP is called a path-vector protocol because BGP carries a sequence of AS numbers that indicate the path taken to a remote network. This information is stored so that routing loops can be avoided.

BGP uses Transmission Control Protocol (TCP) as its Layer 4 protocol (TCP port number 179). No other routing protocol in use today relies on TCP. This allows TCP to ensure that updates are sent reliably, leaving the routing protocol to concentrate on gathering information about remote networks and ensuring a loop-free topology.

Routers configured for BGP are typically called BGP speakers, and any two BGP routers that form a BGP TCP sessions are called BGP peers or BGP neighbors.

BGP peers exchange full BGP routing tables initially. After that, only BGP updates are sent between peers, ensuring that only useful data is sent, unless a change occurs.

BGP4 uses the following four message types to ensure that peers are active and updates are sent:

Open messages— These messages are used when establishing BGP peers.

Keepalives— These messages are sent periodically to ensure that connections are still active or established.

Update messages— Any change that occurs, such as a loss of network availability, results in an update message.

Notification— These messages are used only to notify BGP peers of receiving errors.

The key characteristics of BGP include the following:

• BGP is termed a path vector protocol.

• BGP uses TCP as the transport layer protocol.

• Full routing tables are exchanged only during the initial BGP session.

• Updates are sent over TCP port 179.

• BGP sessions are maintained by keepalive messages.

• Any network changes result in update messages.

• BGP has its own BGP table. Any network entry must reside in the BGP table first.

• BGP has a complex array of metrics, called attributes, which include the next hop address and origin.

• BGP supports variable-length subnet masking (VLSM) and summarization (sometimes called classless interdomain routing [CIDR]).

The capability of BGP4 to guarantee routing delivery and the complexity of the routing decision process ensure that BGP will be widely used in any large IP routing environment, such as the Internet. The Internet consists of over 80,000 BGP network entries, and there is no doubt that only BGP can handle such a complex routing table.

Before you look at some simple examples, the following section describes the BGP attributes.

BGP Attributes

BGP has a number of complex attributes used to determine a path to a remote network. These attributes allow greater flexibility and enable a complex routing decision to ensure that the path to a remote network is the best possible path.

The network designer can also manipulate these attributes. BGP, when supplied with multiple paths to a remote network, always chooses a single path to a specific destination. (Load balancing is possible with static routes.) BGP always propagates the best path to any peers.

BGP attributes are carried in update packets.

Table 6-1 describes the well-known and optional attributes used in BGP4.

Table 6-1. Well-Known and Optional BGP Attributes

Attribute Description

Origin This attribute is mandatory and defines the origin of the path and can have three different values:

• IGP indicates the remote path originated from within the AS.

Typically, when the network command or redistribution is configured, BGP installs the network with an origin set to IGP.

• EBG means learned through an External Gateway Protocol.

• Incomplete means the BGP route was discovered using redistribution or static routers.

AS_Path This attribute describes the sequence of autonomous systems that the packet has traversed.

Next Hop This attribute describes the next hop address taken to a remote path, typically the BGP peer.

Local

Preference This attribute indicates to the AS the preferred path to exit the AS. A higher local preference is always preferred.

MED Multiexit Discriminator informs BGP peers in other autonomous systems which path to take to a remote network. A lower MED is always preferred.

Weight This Cisco-only attribute is used in local router selection. Weight is not sent to other BGP peers, and a higher weight value is always preferred.

The weight value is between 0–294967295.

Atomic This attribute advises BGP routers that aggregation has taken place and is not used in the router-selection process.

Aggregator This is the router ID responsible for aggregation and is not used in the router-selection process.

Community Communities allow routes to be tagged for use with a group of routers sharing the same characteristics.

Originator

ID This attribute is used to prevent routing loops. This information is not used for router selection.

Cluster-List This attribute is used in route-reflector environments. This information is not used for router selection.

Internal BGP (IBGP) and External BGP (EBGP) are the two types of BGP sessions.

IBGP is a connection between two BGP speakers in the same AS. EBGP is a connection between two BGP speakers in different autonomous systems.

Figure 6-1 displays a simple three-router BGP topology and the different BGP connection types: IBGP and EBGP.

Figure 6-1. IBGP and EBGP

IBGP peers also make certain that routing loops cannot occur by ensuring that any routes sent to another AS are known through an interior routing protocol, such as Open Shortest Path First (OSPF), before sending the route information. In other words, the routers must be synchronized. The benefit of this additional rule in IBGP TCP sessions is that information is not sent unless the remote path is reachable, which reduces any unnecessary traffic, and, therefore, saves bandwidth. You can disable this feature with the no synchronization command, which is covered later in this chapter.

The BGP routing decision is quite complex and takes into account the attributes listed in Table 6-1.

The process a Cisco router running BGP4 takes is as follows:

Step 1. If the next hop address is reachable, consider it.

Step 2. Prefer the route with the highest weight (Cisco IOS routers only).

Step 3. If the weight is the same, prefer the largest local preference attribute.

Step 4. If the local preference is the same, prefer the route this local router originated.

Step 5. Prefer the route with the shortest AS path.

Step 6. If this is equal, prefer the route with the origin set to originated (through BGP); IGP is preferred to EGP followed by incomplete.

Step 7. If the origin codes are the same, prefer the route with the lowest MED.

Step 8. If the MED is the same, prefer EBGP over IBGP.

Step 9. Prefer the closest path.

Step 10. Finally, if all paths are equal, prefer the path with lowest BGP router ID.

Configuring BGP

To start BGP on a Cisco router, the following command is required:

router bgp autonomous system number

To define networks to be advertised, apply the following command:

network network-number mask network-mask

You must be aware that the network command is not used in the same way you use it when you apply networks in OSPF or EIGRP. With BGP, you use the network command to advertise networks that originate from the router and need to be advertised through BGP.

To identify peer routers, apply the following command:

neighbor ip-address | peer-group name remote-as autonomous system number

Next, you see how to configure IBGP and EBGP among the three routers in Figure 6- 1. Example 6-1 displays the IBGP configuration on R1 to R2.

Example 6-1 IBGP on R1

R1(config)#router bgp ?

<1-65535> Autonomous system number R1(config)#router bgp 1

R1(config-router)#neighbor 131.108.1.2 remote 1

Example 6-2 displays the IBGP configuration to R1 and EBGP configuration to R3.

Example 6-2 IBGP/EBGP on R2

R2(config)#router bgp 1

R2(config-router)#neighbor 131.108.1.1 remote-as 1 R2(config-router)#neighbor 131.108.255.2 remote-as 2

Finally, Example 6-3 displays the EBGP connection from R3 to R2.

Example 6-3 EBGP on R3

R3(config)#router bgp ?

<1-65535> Autonomous system number R3(config)#router bgp 2

R3(config-router)#neighbor 131.108.255.1 remote-as 1

At this stage, because no network statements have been applied, no BGP entries are on any routers. Use some loopback interfaces on R1 and advertise them through BGP to R2 and R3.

Example 6-4 displays the three new loopback addresses on R1, ranging from 131.108.2.0 to 131.108.4.0.

Example 6-4 Loopback Configuration on R1

R1(config)#interface loopback 0

R1(config-if)#ip address 131.108.2.1 255.255.255.0 R1(config-if)#interface loopback 1

R1(config-if)#ip address 131.108.3.1 255.255.255.0 R1(config-if)#interface loopback 2

R1(config-if)#ip address 131.108.4.1 255.255.255.0

You must next advertise these loopbacks with the network command. Because these networks are local to R1 and present in R1's IP routing table as connected routes, you can apply the network command as displayed in Example 6-5.

Example 6-5 network Command on R1

R1(config)#router bgp 1

R1(config-router)#network 131.108.2.0 mask 255.255.255.0 R1(config-router)#network 131.108.3.0 mask 255.255.255.0 R1(config-router)#network 131.108.4.0 mask 255.255.255.0

Example 6-6 displays the BGP table on R1, using the command show ip bgp.

Example 6-6 show ip bgp on R1

R1#show ip bgp

BGP table version is 4, local router ID is 131.108.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 131.108.2.0/24 0.0.0.0 0 32768 i

*> 131.108.3.0/24 0.0.0.0 0 32768 i

*> 131.108.4.0/24 0.0.0.0 0 32768 i The BGP table on R1 displays three local networks (next hop is 0.0.0.0 or local interfaces). Example 6-6 also displays the path as i, or advertised through BGP. The local router ID is 131.108.1.1.

Example 6-7 displays the BGP table on R2.

Example 6-7 show ip bgp on R2

R2#show ip bgp

BGP table version is 7, local router ID is 171.109.3.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

* i131.108.2.0/24 131.108.1.1 0 100 0 i

* i131.108.3.0/24 131.108.1.1 0 100 0 i

* i131.108.4.0/24 131.108.1.1 0 100 0 i

R2's local router is 131.108.1.2, and it learns the remote loopbacks on R1 through the next hop address 131.108.1.1, or R1's Ethernet interface. Notice that R2 has set the local preference to 100 (default value); the origin attribute is set to i or IGP.

Because R1 and R2 are running only IBGP and no other interior gateway protocol, R2's IP routing table does not have the BGP entries inserted because of

synchronization. Example 6-8 confirms this with only the locally connected routes visible on R2.

Example 6-8 show ip route on R2

R2#show ip route

131.108.0.0/24 is subnetted, 2 subnets

C 131.108.255.0 is directly connected, Serial1/0 C 131.108.1.0 is directly connected, Ethernet0/0

To enable BGP to insert the routes, you must disable synchronization or configure an IGP routing protocol. R2, in turn, does not propagate the loopbacks to R3; therefore, R3 does not have any entries at all, either in the BGP table or IP routing table.

Disable synchronization on R1 and R2. Example 6-9 displays the no synchronization command on R1 and R2.

Example 6-9 Disabling Synchronization on R1/R2

R1(config)#router bgp 1

R1(config-router)#no synchronization

R2(config)#router bgp 1

R2(config-router)#no synchronization

Example 6-10 displays R2's routing table.

Example 6-10 R2's Routing Table

R2#sh ip route

131.108.0.0/24 is subnetted, 5 subnets

C 131.108.255.0 is directly connected, Serial1/0 B 131.108.4.0 [200/0] via 131.108.1.1, 00:00:43 B 131.108.3.0 [200/0] via 131.108.1.1, 00:00:43

B 131.108.2.0 [200/0] via 131.108.1.1, 00:00:43 C 131.108.1.0 is directly connected, Ethernet0/0

The three remote networks are inserted into the IP routing tables as BGP-learned networks.

Example 6-11 displays R3's BGP and IP routing table.

Example 6-11 R3's BGP and IP Tables

R3>show ip bgp

BGP table version is 10, local router ID is 131.108.255.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 131.108.2.0/24 131.108.255.1 0 1 i

*> 131.108.3.0/24 131.108.255.1 0 1 i

*> 131.108.4.0/24 131.108.255.1 0 1 i R3>show ip route

131.108.0.0/24 is subnetted, 5 subnets

C 131.108.255.0 is directly connected, Serial0 B 131.108.4.0 [20/0] via 131.108.255.1, 00:02:09 B 131.108.3.0 [20/0] via 131.108.255.1, 00:02:09 B 131.108.2.0 [20/0] via 131.108.255.1, 00:02:09 C 131.108.1.0 is directly connected, Ethernet0

Notice that the next hop address on R3 is R2. The AS path on R3 indicates that the remote networks, 131.108.2.0 to 131.108.4.0/24, transverse autonomous system number 1, as displayed in the BGP table in Example 6-11.

The following five scenarios examine how BGP is configured and monitored and how BGP can use policy-based routing to change the routing decision of any IP network using powerful tools, such as route maps and the changing the BGP attributes.

Scenarios

The following scenarios are designed to draw together some of the content described in this chapter and some of the content you have seen in your own networks or practice labs. There is no one right way to accomplish many of the tasks presented, and the abilities to use good practice and define your end goal are important in any real-life design or solution. Again, use loopback interfaces to help populate BGP tables, and use back-to-back serial connections among Cisco routers.

Một phần của tài liệu CCNP practical studies routing (Trang 244 - 251)

Tải bản đầy đủ (PDF)

(498 trang)