Route Summarization Without Using Static Routes

Một phần của tài liệu CCNP practical studies routing (Trang 402 - 417)

In this scenario, you revisit the topology in Figure 8-6 and use dynamic routing to insert the non-class C networks into R2's routing table.

Example 8-79 removes the static route configuration on R2.

Example 8-79 Removing the Static Route Configuration on R2

R2(config)#no ip route 131.108.3.0 255.255.255.128 131.108.1.1 R2(config)#no ip route 131.108.3.128 255.255.255.128 131.108.1.1 R2(config)#no ip route 131.108.4.0 255.255.255.248 131.108.1.1

R2(config)#no ip route 131.108.5.0 255.255.255.248 131.108.1.1 The IP routing table on R2 now contains only the 131.108.2.0/24 network, as displayed in Example 8-74.

To redistribute the networks in R1's network, you can apply the summary-address network-mask command.

R1 is an ASBR, so you can use the summary command to send an update to RIP with any mask you need. Because all Cisco IOS routers always choose a path with a more specific route, you can advertise all loopbacks on R1 as Class C subnets to R2.

Example 8-80 configures summarization on R1 for the four loopbacks.

Example 8-80 summary-address Command on R1

R1(config)#router ospf 1

R1(config-router)#summary-address 131.108.3.0 255.255.255.0 R1(config-router)#summary-address 131.108.4.0 255.255.255.0 R1(config-router)#summary-address 131.108.5.0 255.255.255.0 R1(config-router)#redistribute connected subnets

The last c ommand in Example 8-80 ensures that all connected routes (in this case, the loopbacks on R1) are redistributed to R2.

Example 8-81 displays the IP routing table on R2.

Example 8-81 show ip route on R2

R2#show ip route

131.108.0.0/24 is subnetted, 5 subnets

R 131.108.5.0 [120/1] via 131.108.1.1, 00:00:06, Ethernet0/0 R 131.108.4.0 [120/1] via 131.108.1.1, 00:00:06, Ethernet0/0 R 131.108.3.0 [120/1] via 131.108.1.1, 00:00:06, Ethernet0/0 R 131.108.2.0 [120/1] via 131.108.1.1, 00:00:06, Ethernet0/0 C 131.108.1.0 is directly connected, Ethernet0/0

R2 assumes all 131.108.0.0 networks are subnetted as 24-bit networks, as displayed in Example 8-81. To ensure that routing loops cannot occur, R1 sends only the loopbacks interfaces and R2 accepts only routes that are not locally connected.

Example 8-82 configures a route map, called allowout, that permits only the non- class C networks to be advertised to R2.

Example 8-82 Route Map Configuration on R1

R1(config)#router ospf 1

R1(config-router)#redistribute connected subnets route-map allowout R1(config-router)#exit

R1(config)#route-map

R1(config)#route-map allowout R1(config-route-map)#match in

R1(config-route-map)#match interface ? Ethernet IEEE 802.3

Loopback Loopback interface Null Null interface Serial Serial

<cr>

R1(config-route-map)#match interface loopback 1 R1(config-route-map)#match interface loopback 2 R1(config-route-map)#match interface loopback 3 R1(config-route-map)#match interface loopback 4

R1 is configured to permit only the loopback interfaces 1–4 to be redistributed into RIP. Loopback 0 is a Class C subnet route, so you do not need to add this interface.

To ensure that R1 never accepts routes that are locally reachable, configure a distribution list that allows only the loopbacks configured on R1.

Example 8-83 configures a distribution list on R2 permitting only loopbacks 0–4 into R2's IP routing table; all other networks are rejected.

Example 8-83 Distribution List Configuration on R2

R2(config)#router rip

R2(config-router)#distribute-list 1 in R2(config-router)#exit

R2(config)#access-list 1 permit 131.108.2.0 R2(config)#access-list 1 permit 131.108.3.0 R2(config)#access-list 1 permit 131.108.4.0 R2(config)#access-list 1 permit 131.108.5.0

Example 8-84 confirms the IP routing table on R2.

Example 8-84 show ip route rip on R2

R2#show ip route rip

131.108.0.0/24 is subnetted, 5 subnets

R 131.108.5.0 [120/1] via 131.108.1.1, 00:00:00, Ethernet0/0 R 131.108.4.0 [120/1] via 131.108.1.1, 00:00:00, Ethernet0/0 R 131.108.3.0 [120/1] via 131.108.1.1, 00:00:00, Ethernet0/0 R 131.108.2.0 [120/1] via 131.108.1.1, 00:00:00, Ethernet0/0 The same principles applied here can be applied to any number of routers, and as long as route maps and filtering are applied, the network should be free of routing loops and maintain full network connectivity.

Example 8-85 displays R1's full working configuration.

Example 8-85 R1's Full Working Configuration

hostname R1

!

enable password cisco

!

interface Loopback0

ip address 131.108.2.1 255.255.255.0

!

interface Loopback1

ip address 131.108.3.1 255.255.255.128

!

interface Loopback2

ip address 131.108.3.129 255.255.255.128

!

interface Loopback3

ip address 131.108.4.1 255.255.255.248

!

interface Loopback4

ip address 131.108.5.1 255.255.255.248 interface Ethernet0/0

ip address 131.108.1.1 255.255.255.0

!

router ospf 1

summary-address 131.108.3.0 255.255.255.0 summary-address 131.108.4.0 255.255.255.0 summary-address 131.108.5.0 255.255.255.0

redistribute connected subnets route-map allowout network 131.108.2.1 0.0.0.0 area 333

network 131.108.3.1 0.0.0.0 area 333 network 131.108.3.129 0.0.0.0 area 333 network 131.108.4.1 0.0.0.0 area 333 network 131.108.5.1 0.0.0.0 area 333

!

router rip

redistribute ospf 1 metric 1 passive-interface Loopback0 passive-interface Loopback1 passive-interface Loopback2 passive-interface Loopback3 passive-interface Loopback4 network 131.108.0.0

!

route-map allowout permit 10

match interface Loopback1 Loopback2 Loopback3 Loopback4

! end

Example 8-86 displays R2's full working configuration.

Example 8-86 R2's Full Working Configuration

hostname R2

!

enable password cisco

!

ip subnet-zero no ip domain-lookup

!

interface Ethernet0/0

ip address 131.108.1.2 255.255.255.0

!

router rip

network 131.108.0.0 distribute-list 1 in

access-list 1 permit 131.108.5.0

access-list 1 permit 131.108.4.0 access-list 1 permit 131.108.3.0 access-list 1 permit 131.108.2.0

access-list 1 deny 160.100.0.0 0.0.255.255 end

Practical Exercise: Redistribution

NOTE

Practical Exercises are designed to test your knowledge of the topics covered in this chapter. The Practical Exercise begins by giving you some information about a situation and then asks you to work through the solution on your own. The solution can be found at the end.

Figure 8-7 displays a three-router topology running four routing algorithms, all using /24-bit subnet masks. Loopbacks are used on Routers R1 –R3 to populate the

network with IP routing entries.

Figure 8-7. Practical Exercise Topology

Configure all three routers. Use filtering and make extensive use of passive

interfaces to avoid routing loops. Ensure that routing updates are sent to only the relevant interfaces.

Practical Exercise Solution

The issue of FLSM and VLSM is not paramount in this topology because all subnets are /24. So the main issue to be aware of is filtering. Each router is configured for local loopbacks and an interior routing protocol, EIGRP, is configured across the WAN.

After you configure the loopbacks and WAN links are operational, you start by enabling the local LAN interfaces. Then configure redistribution by using filtering wherever required to avoid routing loops. One common troubleshooting scenario is to create a loop by disabling split horizon and then configuring route maps and/or filtering to stop the routing loop—great fun, but only in a practic e lab, of course.

The following configurations provide a sample working solution to the network topology in Figure 8-7. You can, however, configure this network many different ways. Static routes are not used in this design.

R1 is configured for RIP and EIGRP. The redistribution on R1 is filtered to deny any locally sourced networks on R1. All other networks are allowed into R1's IP routing table. The shaded portions in Example 8-87 are key configuration commands for filtering.

Example 8-87 displays R1's full working configuration.

Example 8-87 R1's Full Working Configuration

hostname R1

!

enable password cisco

!

ip subnet-zero interface Loopback0

ip address 141.108.2.1 255.255.255.0

!

interface Loopback1

ip address 141.108.3.1 255.255.255.0

!

interface Loopback2

ip address 141.108.4.1 255.255.255.0

!

interface Loopback3

ip address 141.108.5.1 255.255.255.0

!

interface Loopback4

ip address 141.108.6.1 255.255.255.0

!

interface Loopback5

ip address 141.108.7.1 255.255.255.0

!

interface Loopback6

ip address 141.108.0.1 255.255.255.0

!

interface Ethernet0/0

ip address 141.108.1.1 255.255.255.0

!

interface Serial1/0 bandwidth 128

ip address 151.108.255.1 255.255.255.0 clockrate 128000

!

interface Serial1/1 bandwidth 128

ip address 151.108.254.1 255.255.255.0 clockrate 128000

!

router eigrp 1

redistribute rip metric 128 20000 255 1 1500 network 151.108.0.0

distribute-list 1 in

!

router rip

passive-interface Serial1/0 passive-interface Serial1/1 network 141.108.0.0

!

ip classless

!

access-list 1 deny 141.108.0.0 0.0.7.255 access-list 1 permit any

!

line con 0 line aux 0 line vty 0 4 end

Example 8-88 displays R2's full working configuration.

Example 8-88 R2's Full Working Configuration

hostname R2

!

enable password cisco

!

ip subnet-zero

!

interface Loopback0

ip address 141.108.9.1 255.255.255.0

!

interface Loopback1

ip address 141.108.10.1 255.255.255.0

!

interface Loopback2

ip address 141.108.11.1 255.255.255.0

!

interface Loopback3

ip address 141.108.12.1 255.255.255.0

!

interface Loopback4

ip address 141.108.13.1 255.255.255.0

!

interface Loopback5

ip address 141.108.14.1 255.255.255.0

!

interface Loopback6

ip address 141.108.15.1 255.255.255.0

!

interface Ethernet0/0

ip address 141.108.8.1 255.255.255.0

!

interface Serial1/0 bandwidth 128

ip address 151.108.255.2 255.255.255.0 interface Serial1/1

bandwidth 128

ip address 151.108.253.2 255.255.255.0

!

router eigrp 1

network 151.108.0.0 distribute-list 1 in

!

router igrp 1

passive-interface Serial1/0 passive-interface Serial1/1 network 141.108.0.0

!

ip classless

!

access-list 1 deny 141.108.8.0 0.0.7.255 access-list 1 permit any

!

line con 0 line aux 0 line vty 0 4

! end

Example 8-89 displays R3's full working configuration.

Example 8-89 R3's Full Working Configuration

hostname R3

!

enable password cisco

!

no ip domain-lookup

!

interface Loopback0

ip address 141.108.17.1 255.255.255.0

!

interface Loopback1

ip address 141.108.18.1 255.255.255.0

!

interface Loopback2

ip address 141.108.19.1 255.255.255.0

!

interface Loopback3

ip address 141.108.20.1 255.255.255.0

!

interface Loopback4

ip address 141.108.21.1 255.255.255.0

!

interface Loopback5

ip address 141.108.22.1 255.255.255.0

!

interface Loopback6

ip address 141.108.23.1 255.255.255.0

!

interface Ethernet0

ip address 141.108.16.1 255.255.255.0 media-type 10BaseT

!

interface Ethernet1 no ip address

!

interface Serial0

ip address 151.108.254.2 255.255.255.0 bandwidth 128

!

interface Serial1

ip address 151.108.253.1 255.255.255.0 bandwidth 128

clockrate 128000

!

router eigrp 1

redistribute ospf 1 metric 128 20000 1 1 1500 network 151.108.0.0

distribute-list 1 in

!

router ospf 1

network 141.108.16.0 0.0.7.255 area 100

!

ip classless

access-list 1 deny 141.108.16.0 0.0.7.255 access-list 1 permit any

!

line con 0 line aux 0 line vty 0 4

! end

Example 8-90 displays the IP routing table on R1, demonstrating full network connectivity.

Example 8-90 show ip route on R1

R1#show ip route

141.108.0.0/24 is subnetted, 24 subnets

C 141.108.1.0 is directly connected, Ethernet0/0 C 141.108.0.0 is directly connected, Loopback6 C 141.108.3.0 is directly connected, Loopback1 C 141.108.2.0 is directly connected, Loopback0 C 141.108.5.0 is directly connected, Loopback3 C 141.108.4.0 is directly connected, Loopback2 C 141.108.7.0 is directly connected, Loopback5 C 141.108.6.0 is directly connected, Loopback4

D EX 141.108.9.0 [170/20640000] via 151.108.255.2, 00:06:20, Serial1/0

D EX 141.108.8.0 [170/20537600] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.11.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.10.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.13.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.12.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.15.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.14.0 [170/20640000] via 151.108.255.2, 00:06:21, Serial1/0

D EX 141.108.17.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.16.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.19.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.18.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.21.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.20.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.23.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

D EX 141.108.22.0 [170/25632000] via 151.108.254.2, 00:06:22, Serial1/1

151.108.0.0/24 is subnetted, 3 subnets

C 151.108.255.0 is directly connected, Serial1/0 C 151.108.254.0 is directly connected, Serial1/1

D 151.108.253.0 [90/21024000] via 151.108.254.2, 00:06:22, Serial1/1

[90/21024000] via 151.108.255.2, 00:06:22, Serial1/0

R1#

The redistributed networks from R2 and R3 appear as external EIGRP routes (D EX).

Also, because the composite metric to the WAN network 151.108.253.0/24 is the same, EIGRP is load balancing. The EIGRP topology table on R1 confirms the same composite metric.

Example 8-91 displays the EIGRP topology table on R1. The shaded portions display the dual path to 151.108.253.0.

Example 8-91 show ip eigrp topology on R1

R1#show ip eigrp topology

IP-EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - Reply status

P 151.108.255.0/24, 1 successors, FD is 20512000 via Connected, Serial1/0

P 151.108.254.0/24, 1 successors, FD is 20512000 via Connected, Serial1/1

P 151.108.253.0/24, 2 successors, FD is 21024000

via 151.108.255.2 (21024000/20512000), Serial1/0 via 151.108.254.2 (21024000/20512000), Serial1/1 P 141.108.1.0/24, 1 successors, FD is 25120000

via Redistributed (25120000/0)

P 141.108.0.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.3.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.2.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.5.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.4.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.7.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.6.0/24, 1 successors, FD is 25120000 via Redistributed (25120000/0)

P 141.108.9.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.8.0/24, 1 successors, FD is 20537600

via 151.108.255.2 (20537600/281600), Serial1/0 P 141.108.11.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.10.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.13.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.12.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.15.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.14.0/24, 1 successors, FD is 20640000

via 151.108.255.2 (20640000/128256), Serial1/0 P 141.108.17.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.16.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.19.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.18.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.21.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.20.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.23.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 P 141.108.22.0/24, 1 successors, FD is 25632000

via 151.108.254.2 (25632000/25120000), Serial1/1 R1#

Example 8-92 confirms network IP connectivity by pinging all the remote networks from R1.

Example 8-92 Pinging Remote Networks on R1

R1#ping 141.108.8.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.8.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms R1#ping 141.108.9.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.9.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.10.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.11.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.11.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/17 ms R1#ping 141.108.12.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.12.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.13.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.13.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.14.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.14.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.15.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.15.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.16.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.16.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms R1#ping 141.108.17.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.17.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms R1#ping 141.108.18.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.18.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.19.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.19.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.20.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms R1#ping 141.108.21.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.21.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/17 ms R1#ping 141.108.22.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.22.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/17 ms R1#ping 141.108.23.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 141.108.23.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#

Review Questions

The answers to these question can be found in Appendix C, “Answers to Review Questions.”

1: How many IP routing tables are there when more than one routing protocol is configured on a Cisco router?

2: Which path is preferred if OSPF and EIGRP have dynamically discovered a remote network?

3: What common methods are used to control routing updates and filtering?

4: What is the metric used by OSPF, and is the lower or higher metric the chosen path?

5: Is a static route always preferred over a directly connected route?

6: Which command stops updates from being sent out of any interface?

7: Which parameter does the Cisco IOS always compare before looking at routing metrics, such as hop count or OSPF cost?

8: Give two examples of classful protocols?

9: Give two examples of classless protocols?

10: What are the three methods commonly applied to avoid routing loops when redistribution is required?

Summary

Redistribution from one routing protocol to another has been extensively covered in this chapter. The issues of routing loops and metric conversion from one routing protocol to another have been demonstrated, and you should now have the skills necessary to enable any form of route redistribution. Routing between classless and classful domains is one of the major learning tools you must master quickly in any IP network. In such a situation, information can be controlled to ensure that the

network is routing IP as correctly and efficiently as possible.

Mastering distribution lists, static routing, and route maps enables you to avoid routing loops and ensure that full IP connectivity still exists.

You should now be ready to apply the information in this and all of the previous chapters to the self-study lab in Chapter 9, “CCNP Routing Self-Study Lab.”

Table 8-3 summarizes the most important commands used in this chapter.

Table 8-3. Summary of IOS Commands

Command Purpose

area area-id range

address mask Summarizes OSPF network ranges.

router ospf process id Enables OSPF routing. The process ID is local to the router.

You can have more than one OSPF process ID running.

router eigrp

autonomous domain ID Enables EIGRP routing under a common administrative control, known as the autonomous domain.

no auto-summary Disables automatic summarization.

show ip route Displays the complete IP routing table.

show ip eigrp

topology Displays the EIGRP topology table. Useful for determining other paths available on an EIGRP router.

[no] shutdown Enables or disables an interface. All hardware interfaces are shut down by default.

ping ip-address Tests IP connectivity.

redistribute options Enables redistribution. See Table 8-2 for a complete listing of available options.

passive-interface Disables updates sent outbound but still listens to updates.

Một phần của tài liệu CCNP practical studies routing (Trang 402 - 417)

Tải bản đầy đủ (PDF)

(498 trang)