Route Summarization Using Static Routes

Một phần của tài liệu CCNP practical studies routing (Trang 398 - 402)

The internetwork in Figure 8-6 displays a simple two-router topology with two routing algorithms in use. This scenario contains only two routers, so you can easily replicate this network with your own set of Cisco IOS routers.

Figure 8-6. Routing IP Between RIP and OSPF

The end goal of this scenario is to ensure full IP connectivity between the two different IP networks. The ability to configure networks from a classless and classful domain and vice versa is critical. This scenario is designed to ensure that you are fully aware of all the potential problems when routing between OSPF (classless routing protocol) and RIP (classful routing protocol).

Router R1 has a number of interfaces in OSPF area 333, and R2 is running RIP only.

This scenario uses static routes to ensure connectivity between the classless (RIP) domain to the classful (OSPF) domain.

You configure R1 for redistribution between RIP and OSPF.

Example 8-71 configures R1 for IP addressing and enables OSPF and RIP. Ensure that RIP updates are sent to only the Ethernet interfaces on R1 by configuring R1 with passive interfaces, even on the loopbacks, because OSPF advertises these routes. To ensure that routing resources are not wasted, allow only one routing algorithm to advertise each interface. To do this, you apply passive interfaces where required.

Example 8-71 R1 Configuration

R1(config)#interface Loopback0

R1(config-if)# ip address 131.108.2.1 255.255.255.0 R1(config-if)#interface Loopback1

R1(config-if)# ip address 131.108.3.1 255.255.255.128 R1(config-if)#interface Loopback2

R1(config-if)# ip address 131.108.3.129 255.255.255.128 R1(config-if)#interface Loopback3

R1(config-if)# ip address 131.108.4.1 255.255.255.248 R1(config-if)#interface Loopback4

R1(config-if)# ip address 131.108.5.1 255.255.255.248 R1(config)#router ospf 1

R1(config-router)#network 131.108.2.1 0.0.0.0 area 333 R1(config-router)#network 131.108.3.1 0.0.0.0 area 333 R1(config-router)#network 131.108.3.129 0.0.0.0 area 333 R1(config-router)#network 131.108.4.1 0.0.0.0 area 333 R1(config-router)#network 131.108.5.1 0.0.0.0 area 333 R1(config-router)#router rip

R1(config-router)#network 131.108.0.0 R1(config-router)#pass

R1(config-router)#passive-interface lo0 R1(config-router)#passive-interface lo1 R1(config-router)#passive-interface lo2 R1(config-router)#passive-interface lo3 R1(config-router)#passive-interface lo4 Example 8-72 enables IP RIP on R2.

Example 8-72 RIP Configuration on R2

R2(config)#interface ethernet 0/0

R2(config-if)#ip address 131.108.1.2 255.255.255.0 R2(config-if)#exit

R2(config)#router rip

R2(config-router)#network 131.108.0.0

To enable R2 to learn the OSPF loopback interfaces on R1 dynamically, enable RIP- to-OSPF redistribution on R1, by setting the metric to 1 (hop count).

Example 8-73 displays the redistribution on R1 from RIP to OSPF.

Example 8-73 Redistribution on R1 from RIP to OSPF

R1(config)#router rip

R1(config-router)#redistribute ospf 1 metric 1

View the IP routing table on R2 to determine which RIP networks R1 advertises to R2.

Example 8-74 displays the IP routing table on R1.

Example 8-74 show ip route R1

R2#show ip route

131.108.0.0/24 is subnetted, 2 subnets

R 131.108.2.0 [120/1] via 131.108.1.1, 00:00:06, Ethernet0/0 C 131.108.1.0 is directly connected, Ethernet0/0

The only IP network in Example 8-74 is the subnet 131.108.2.0, which is a Class C subnetted route. Because R2 is configured with a classful routing protocol, only 24- bit networks are advertised by R1 and accepted by R2. You can use two methods to solve this scenario. The first is to use static routes, and the second method uses summarization techniques on R1.

Configure R2 with static routes and ensure network connectivity to R1 loopback interfaces.

Example 8-75 configures R2 with four static routes pointing to the next hop destination to R1's Ethernet IP address of 131.108.1.1.

Example 8-75 Static Route Configuration on R2

R2(config)#ip route 131.108.3.0 255.255.255.128 131.108.1.1 R2(config)#ip route 131.108.3.128 255.255.255.128 131.108.1.1 R2(config)#ip route 131.108.4.0 255.255.255.248 131.108.1.1 R2(config)#ip route 131.108.5.0 255.255.255.248 131.108.1.1

R2 is configured with static routing information, even though the remote networks are not Class C subnets. Confirm network connectivity by viewing the IP routing table on R2 and pinging all remote loopback interfaces on R1.

Example 8-76 displays R2's IP routing table and five ping requests to all R1's loopback interfaces.

Example 8-76 show ip route and ping on R2

R2#show ip route

Codes: C - connected, S - static,R - RIP

131.108.0.0/16 is variably subnetted, 6 subnets, 3 masks S 131.108.3.128/25 [1/0] via 131.108.1.1

S 131.108.5.0/29 [1/0] via 131.108.1.1 S 131.108.4.0/29 [1/0] via 131.108.1.1 S 131.108.3.0/25 [1/0] via 131.108.1.1

R 131.108.2.0/24 [120/1] via 131.108.1.1, 00:00:13, Ethernet0/0 C 131.108.1.0/24 is directly connected, Ethernet0/0

R2#ping 131.108.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 131.108.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

R2#ping 131.108.3.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 131.108.3.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms R2#ping 131.108.3.129

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 131.108.3.129, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms R2#ping 131.108.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 131.108.4.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms R2#ping 131.108.5.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 131.108.5.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms R2#

Example 8-76 displays IP networks installed in the routing table. Even though RIP is classful, you can use static routes to overcome the limitations of routing between VLSM networks or fixed-length subnet mask (FLSM) networks.

In the next scenario, you configure routing between VLSM and FLSM networks without using static routing.

Example 8-77 displays R1's full working configuration.

Example 8-77 R1's Full Working Configuration

hostname R1

!

enable password cisco

!

ip subnet-zero interface Loopback0

ip address 131.108.2.1 255.255.255.0

!

interface Loopback1

ip address 131.108.3.1 255.255.255.128 interface Loopback2

ip address 131.108.3.129 255.255.255.128 interface Loopback3

ip address 131.108.4.1 255.255.255.248

!

interface Loopback4

ip address 131.108.5.1 255.255.255.248

!

interface Ethernet0/0

ip address 131.108.1.1 255.255.255.0 router ospf 1

network 131.108.2.1 0.0.0.0 area 333 network 131.108.3.1 0.0.0.0 area 333

network 131.108.3.129 0.0.0.0 area 333 network 131.108.4.1 0.0.0.0 area 333 network 131.108.5.1 0.0.0.0 area 333

!

router rip

redistribute ospf 1 metric 1 passive-interface Loopback0 passive-interface Loopback1 passive-interface Loopback2 passive-interface Loopback3 passive-interface Loopback4 network 131.108.0.0

! end

Example 8-78 displays R2's full working configuration.

Example 8-78 R2's Full Working Configuration (Truncated)

hostname R2

!

enable password cisco

!

ip subnet-zero no ip domain-lookup

!

interface Ethernet0/0

ip address 131.108.1.2 255.255.255.0

!

router rip

network 131.108.0.0

!

ip route 131.108.3.0 255.255.255.128 131.108.1.1 ip route 131.108.3.128 255.255.255.128 131.108.1.1 ip route 131.108.4.0 255.255.255.248 131.108.1.1 ip route 131.108.5.0 255.255.255.248 131.108.1.1 end

Một phần của tài liệu CCNP practical studies routing (Trang 398 - 402)

Tải bản đầy đủ (PDF)

(498 trang)