In this scenario, you migrate a typical RIP network to OSPF in the core of the network and leave RIP on the edge of the network, where typically, on LAN-based segments, bandwidth is not a major concern.
IP addressing and loopback address assignments have already been completed.
Figure 8-3 displays the current RIP network that you migrate to OSPF.
Figure 8-3. RIP Topology
Loopbacks have been configured in R1, R2, and R3 to populate the IP routing tables.
The Class B network, 141.108.0.0, has been subnetted using a Class C mask
throughout. Because all RIP-enabled routers have a local interface configured using a Class C mask, network connectivity is maintained.
The current IP routing table on R1 is displayed in Example 8-21.
Example 8-21 show ip route on R1
R3#show ip route
141.108.0.0/24 is subnetted, 26 subnets
R 141.108.253.0 [120/1] via 141.108.255.2, 00:00:15, Serial1/0 [120/1] via 141.108.254.2, 00:00:11, Serial1/1 C 141.108.255.0 is directly connected, Serial1/0
C 141.108.254.0 is directly connected, Serial1/1 C 141.108.1.0 is directly connected, Ethernet0/0 C 141.108.3.0 is directly connected, Loopback1 C 141.108.2.0 is directly connected, Loopback0 C 141.108.5.0 is directly connected, Loopback3 C 141.108.4.0 is directly connected, Loopback2 C 141.108.7.0 is directly connected, Loopback5 C 141.108.6.0 is directly connected, Loopback4
R 141.108.9.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.8.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.11.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.10.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.13.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.12.0 [120/1] via 141.108.255.2, 00:00:16, Serial1/0 R 141.108.15.0 [120/1] via 141.108.255.2, 00:00:17, Serial1/0 R 141.108.14.0 [120/1] via 141.108.255.2, 00:00:17, Serial1/0 R 141.108.17.0 [120/1] via 141.108.254.2, 00:00:12, Serial1/1 R 141.108.16.0 [120/1] via 141.108.254.2, 00:00:12, Serial1/1 R 141.108.19.0 [120/1] via 141.108.254.2, 00:00:12, Serial1/1 R 141.108.18.0 [120/1] via 141.108.254.2, 00:00:12, Serial1/1 R 141.108.21.0 [120/1] via 141.108.254.2, 00:00:12, Serial1/1 R 141.108.20.0 [120/1] via 141.108.254.2, 00:00:13, Serial1/1 R 141.108.23.0 [120/1] via 141.108.254.2, 00:00:13, Serial1/1 R 141.108.22.0 [120/1] via 141.108.254.2, 00:00:13, Serial1/1
Example 8-21 displays over 25 different networks. The main aim of converting the routing algorithm from RIP to OSPF is to enable VLSM in the WAN and summarization among routers to reduce IP routing table sizes.
Example 8-22 displays the current working configuration on R1 running RIP as the primary routing algorithm.
Example 8-22 R1's RIP Configuration
hostname R1
!
enable password cisco
!
ip subnet-zero
!
interface Loopback0
ip address 141.108.2.1 255.255.255.0
!
interface Loopback1
ip address 141.108.3.1 255.255.255.0
!
interface Loopback2
ip address 141.108.4.1 255.255.255.0
!
interface Loopback3
ip address 141.108.5.1 255.255.255.0
!
interface Loopback4
ip address 141.108.6.1 255.255.255.0
!
interface Loopback5
ip address 141.108.7.1 255.255.255.0
!
interface Ethernet0/0
ip address 141.108.1.1 255.255.255.0 interface Serial1/0
ip address 141.108.255.1 255.255.255.0 clockrate 128000
!
interface Serial1/1
ip address 141.108.254.1 255.255.255.0 clockrate 128000
!
router rip
network 141.108.0.0
!
line con 0 end
Example 8-23 displays R2's current working configuration.
Example 8-23 R2's RIP Configuration
hostname R2
!
enable password cisco interface Loopback0
ip address 141.108.9.1 255.255.255.0
!
interface Loopback1
ip address 141.108.10.1 255.255.255.0
!
interface Loopback2
ip address 141.108.11.1 255.255.255.0
!
interface Loopback3
ip address 141.108.12.1 255.255.255.0
!
interface Loopback4
ip address 141.108.13.1 255.255.255.0
!
interface Loopback5
ip address 141.108.14.1 255.255.255.0
!
interface Loopback6
ip address 141.108.15.1 255.255.255.0
!
interface Ethernet0/0
ip address 141.108.8.1 255.255.255.0
!
interface Serial1/0 bandwidth 128
ip address 141.108.255.2 255.255.255.0
!
interface Serial1/1
ip address 141.108.253.2 255.255.255.0 router rip
network 141.108.0.0
!
ip classless
! end
Example 8-24 displays R3's current working configuration.
Example 8-24 R3's RIP Configuration
hostname R3
!
enable password cisco
!
no ip domain-lookup
!
interface Loopback0
ip address 141.108.17.1 255.255.255.0
!
interface Loopback1
ip address 141.108.18.1 255.255.255.0
!
interface Loopback2
ip address 141.108.19.1 255.255.255.0
!
interface Loopback3
ip address 141.108.20.1 255.255.255.0
!
interface Loopback4
ip address 141.108.21.1 255.255.255.0
!
interface Loopback5
ip address 141.108.22.1 255.255.255.0
!
interface Loopback6
ip address 141.108.23.1 255.255.255.0
!
interface Ethernet0
ip address 141.108.16.1 255.255.255.0
!
interface Serial0
ip address 141.108.254.2 255.255.255.0 bandwidth 125
!
interface Serial1
ip address 141.108.253.1 255.255.255.0 bandwidth 125
clockrate 125000
!
router rip
network 141.108.0.0
! end
To start, add OSPF to the center of the network, and place all the WAN interfaces in area 0. Maintain the Class C mask for now to make redistribution relativity easy to configure. This step is common when migrating from one protocol to another.
Example 8-25 configures R1 for OSPF across the WAN to R1 and R2. You take the same configuration steps on R2 and R3.
Example 8-25 OSPF Configuration on R1
R1(config)#router ospf1
R1(config-router)#network 141.108.255.0 0.0.0.255 area 0 R1(config-router)#network 141.108.254.0 0.0.0.255 area 0 R1(config-router)#router rip
R1(config-router)#passive-interface serial 1/0 R1(config-router)#passive-interface serial 1/1
R1 is configured not to send any RIP updates to Serial 1/0 (to R2) and Serial 1/1 (to R3); this configuration stops the sending of unnecessary updates across WAN links.
At this stage, you have not configured any redistribution, so there is no connectivity among the Ethernet and loopback interfaces. Example 8-26 confirms the status of IP connectivity after the show ip route command is entered on R1.
Example 8-26 show ip route on R1
R1#show ip route
141.108.0.0/24 is subnetted, 10 subnets
O 141.108.253.0 [110/1562] via 141.108.255.2, 00:00:04, Serial1/0 C 141.108.255.0 is directly connected, Serial1/0
C 141.108.254.0 is directly connected, Serial1/1 C 141.108.1.0 is directly connected, Ethernet0/0 C 141.108.3.0 is directly connected, Loopback1 C 141.108.2.0 is directly connected, Loopback0 C 141.108.5.0 is directly connected, Loopback3 C 141.108.4.0 is directly connected, Loopback2 C 141.108.7.0 is directly connected, Loopback5 C 141.108.6.0 is directly connected, Loopback4
The only visible route on R1 is the locally connected routes and the WAN circuit between R2 and R3.
Next, configure redistribution on routers R1, R2, and R3 to advertise the RIP networks to the OSPF backbone.
Example 8-27 displays the RIP to OSPF redistribution on R1. Example 8-27 also displays redistribution from OSPF to RIP to allow communication from R2/R3
Ethernet segments to R1's locally connected network, which, at the moment, is advertised by only RIP. The ? tool is used to display the available options.
Example 8-27 Redistribution on R1
R1(config)#router ospf 1
R1(config-router)#redistribute rip metric ? <0-16777214> OSPF default metric
R1(config-router)#redistribute rip metric 100 subnets R1(config-router)#exit
R1(config)#router rip
R1(config-router)#redistribute ospf 1 metric ? <0-4294967295> Default metric
R1(config-router)#redistribute ospf 1 metric 3 R1(config-router)#distribute-list 1 out
R1(config-router)#exit
R1(config)#access-list 1 deny 141.108.1.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.2.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.3.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.4.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.5.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.6.0 0.0.0.255 R1(config)#access-list 1 deny 141.108.7.0 0.0.0.255 R1(config)#access-list 1 permit any
R1 is now configured to redistribute from RIP to OSPF and vice versa. Example 8-27 displays the keyword subnets because the Class B network 141.108.0.0 has been subnetted across the network. Without this keyword, only classful networks would not be advertised. (In this case, you are using classless networks on all routers.) Also, the metrics have been set to 100 for all RIP-to-OSPF networks, and the hop count for all redistributed OSPF networks into RIP is set to 3.
Typically, networks have some other paths or back doors between any given routing topologies. To ensure that networks residing on R1 are never advertised by the OSPF backbone, the distribution list on R1 denies any networks residing in 141.108.1.0–
141.108.7.255 from being advertised from OSPF to RIP. This ensures that a routing loop cannot occur.
The access list 1, previously defined with seven statements, can be replaced with the configuration in Example 8-28 to deny the range of networks 141.108.0.0–
141.108.7.0 and permit all other networks.
Example 8-28 replaces the seven-line access list with two lines of IOS configuration.
(The no access-list 1 command removes the configuration currently present for access list 1.)
Example 8-28 Access List Configuration on R1
R1(config)#no access-list 1
R1(config)#access-list 1 deny 141.108.0.0 0.0.7.255 R1(config)#access-list 1 permit any
Example 8-29 displays the redistribution and filtering required on R2.
Example 8-29 Redistribution on R2
R2(config)#router rip
R2(config-router)#distribute-list 1 out
R2(config-router)#redistribute ospf 1 metric 3 R2(config-router)#router ospf 1
R2(config-router)#redistribute rip metric 10 subnets R2(config)#access-list 1 deny 141.108.8.0 0.0.7.255 R2(config)#access-list 1 permit any
Example 8-30 displays the redistribution and filtering on R3.
Example 8-30 Redistribution on R3
R3(config)#router rip
R3(config-router)#redistribute ospf 1 metric 3 R3(config-router)#distribute-list 1 out
R3(config-router)#router ospf 1
R3(config-router)#redistribute rip metric 10 subnets R3(config-router)#exit
R3(config)#access-list 1 deny 141.108.23.0 0.0.7.255 R3(config)#access-list 1 permit any
Confirm IP routing connectivity from R1. Example 8-31 displays the IP routing table on R1 and some sample ping requests that conform IP connectivity.
Example 8-31 show ip route and Pings on R1
R1#show ip route
Codes: C - connected,E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
141.108.0.0/24 is subnetted, 26 subnets
O 141.108.253.0 [110/1562] via 141.108.255.2, 00:00:51, Serial1/0 C 141.108.255.0 is directly connected, Serial1/0
C 141.108.254.0 is directly connected, Serial1/1 C 141.108.1.0 is directly connected, Ethernet0/0 C 141.108.3.0 is directly connected, Loopback1 C 141.108.2.0 is directly connected, Loopback0 C 141.108.5.0 is directly connected, Loopback3 C 141.108.4.0 is directly connected, Loopback2 C 141.108.7.0 is directly connected, Loopback5 C 141.108.6.0 is directly connected, Loopback4
O E2 141.108.9.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.8.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.11.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.10.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.13.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.12.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.15.0 [110/10] via 141.108.255.2, 00:00:51, Serial1/0 O E2 141.108.14.0 [110/10] via 141.108.255.2, 00:00:52, Serial1/0 O E2 141.108.17.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.16.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.19.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.18.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.21.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.20.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 O E2 141.108.23.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1
O E2 141.108.22.0 [110/10] via 141.108.254.2, 00:00:52, Serial1/1 R1#ping 141.108.9.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 141.108.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 141.108.22.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 141.108.22.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms The next step in migration is to remove RIP and enable OSPF across all interfaces in the networks. Before you complete this migration, look at the routing configurations on Routers R1, R2, and R3.
Example 8-32 displays the IP routing configuration on R1.
Example 8-32 show running-config (Truncated) on R1
router ospf 1
redistribute rip metric 100 subnets network 141.108.254.0 0.0.0.255 area 0 network 141.108.255.0 0.0.0.255 area 0
!
router rip
redistribute ospf 1 metric 3 passive-interface Serial1/0 passive-interface Serial1/1 network 141.108.0.0
distribute-list 1 out
access-list 1 deny 141.108.0.0 0.0.7.255 access-list 1 permit any
Example 8-33 displays the IP routing configuration on R2.
Example 8-33 show running-config (Truncated) on R2
router ospf 1
redistribute rip metric 10 subnets network 141.108.253.0 0.0.0.255 area 0 network 141.108.255.0 0.0.0.255 area 0
!
router rip
redistribute ospf 1 metric 3 passive-interface Serial1/0 passive-interface Serial1/1 network 141.108.0.0
distribute-list 1 out
!
ip classless
!
access-list 1 deny 141.108.8.0 0.0.7.255 access-list 1 permit any
Example 8-34 displays the IP routing configuration on R3.
Example 8-34 show running-config (Truncated) on R3
router ospf 1
redistribute rip metric 10 subnets network 141.108.254.0 0.0.0.255 area 0 network 141.108.253.0 0.0.0.255 area 0
!
router rip
redistribute ospf 1 metric 3 passive-interface Serial0 passive-interface Serial1 network 141.108.0.0
distribute-list 1 out
!
access-list 1 deny 141.108.16.0 0.0.7.255 access-list 1 permit any
Figure 8-4 displays the OSPF area assignment to complete the RIP to OSPF migration.
Figure 8-4. OSPF Area Assignments
Figure 8-4 displays the OSPF area assignment along with the ability to re-address the WAN circuit to /30 subnets because OSPF understands VLSM.
Example 8-35 displays the removal of RIP on R1 and the OSPF and IP address assignment on R1. Also, note the new IP address assignment for the WAN links with /30 subnets.
Example 8-35 Removal of RIP on R1 and OSPF/IP Address Assignment
R1(config)#no router rip R1(config)#router ospf 1
R1(config-router)#network 141.108.255.0 0.0.0.255 area 0 R1(config-router)#network 141.108.0.0 0.0.7.255 area 1 R1(config)#interface s1/0
R1(config-if)#ip address 141.108.255.1 255.255.255.252 R1(config-if)#interface s1/1
R1(config-if)#ip address 141.108.255.5 255.255.255.252
Example 8-36 displays the removal of RIP on R2 and the OSPF and IP address assignment on R2.
Example 8-36 Removal of RIP on R2 and OSPF/IP Address Assignment
R2(config)#no router rip R2(config)#router ospf 1
R2(config-router)#network 141.108.255.0 0.0.0.255 area 0 R2(config-router)#network 141.108.8.0 0.0.7.255 area 2 R2(config-router)#exit
R2(config)#interface s1/0
R2(config-if)#ip address 141.108.255.2 255.255.255.252 R2(config-if)#interface s1/1
R2(config-if)#ip address 141.108.255.10 255.255.255.252
Example 8-37 displays the removal of RIP on R3 and the OSPF and IP address assignment on R3.
Example 8-37 Removal of RIP on R3 and OSPF/IP Address Assignment
R3(config)#router ospf 1
R3(config-router)#network 141.108.23.0 0.0.7.255 area 3 R3(config-router)#network 141.108.255.0 0.0.0.255 area 0 R3(config-router)#exit
R3(config)#interface serial0
R3(config-if)#ip address 141.108.255.6 255.255.255.252 R3(config-if)#interface serial1
R3(config-if)#ip address 141.108.255.9 255.255.255.252
NOTE
Removing RIP from Routers R1, R2, and R3 causes the Cisco IOS to remove any redistribution between RIP and OSPF automatically. Therefore, manual removal of redistribution is not required on Routers R1, R2, and R3.
Now that OSPF is configured across all routers, view the IP routing table on R1.
Example 8-38 displays R1's IP routing table.
Example 8-38 R1's IP Routing Table
R1#show ip route
Codes: C - connected, , O - OSPF, IA - OSPF inter area
141.108.0.0/16 is variably subnetted, 26 subnets, 3 masks O 141.108.255.8/30 [110/1562] via 141.108.255.2, 00:00:27, Serial1/0
C 141.108.255.4/30 is directly connected, Serial1/1 C 141.108.255.0/30 is directly connected, Serial1/0 C 141.108.1.0/24 is directly connected, Ethernet0/0 C 141.108.3.0/24 is directly connected, Loopback1 C 141.108.2.0/24 is directly connected, Loopback0 C 141.108.5.0/24 is directly connected, Loopback3 C 141.108.4.0/24 is directly connected, Loopback2 C 141.108.7.0/24 is directly connected, Loopback5 C 141.108.6.0/24 is directly connected, Loopback4
O IA 141.108.9.1/32 [110/782] via 141.108.255.2, 00:00:27, Serial1/0 O IA 141.108.8.0/24 [110/791] via 141.108.255.2, 00:00:27, Serial1/0 O IA 141.108.10.1/32 [110/782] via 141.108.255.2, 00:00:27,
Serial1/0
O IA 141.108.11.1/32 [110/782] via 141.108.255.2, 00:00:27, Serial1/0
O IA 141.108.12.1/32 [110/782] via 141.108.255.2, 00:00:27, Serial1/0
O IA 141.108.13.1/32 [110/782] via 141.108.255.2, 00:00:28, Serial1/0
O IA 141.108.14.1/32 [110/782] via 141.108.255.2, 00:00:28, Serial1/0
O IA 141.108.15.1/32 [110/782] via 141.108.255.2, 00:00:28, Serial1/0
O IA 141.108.17.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.16.0/24 [110/791] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.18.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.19.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.20.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.21.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.22.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
O IA 141.108.23.1/32 [110/782] via 141.108.255.6, 00:00:28, Serial1/1
In Example 8-32, the redistributed routes appear as E2 (External Type 2) and OSPF is configured across all three routers. The OSPF type route is displayed as O IA in Example 8-38.
OSPF can support VLSM and network summarization, so configure each router in Figure 8-4 to summarize locally connected routes, which are contiguous. (All routers
are ABRs because each router resides in areas 0, 1, 2, or 3.) Example 8-39 displays the summarization for networks 141.108.0.0–141.108.7.0. To summarize internal OSPF routes, the area area-id range network subnet mask IOS command is required.
The loopback addresses on R1 reside in OSPF area 1. Example 8-39 displays the area summary command on R1.
Example 8-39 Area Summary on R1
R1(config)#router ospf 1 R1(config-router)#area 1 ?
authentication Enable authentication
default-cost Set the summary default-cost of a NSSA/stub area nssa Specify a NSSA area
range Summarize routes matching address/mask (border routers only)
stub Specify a stub area
virtual-link Define a virtual link and its parameters R1(config-router)#area 1 range ?
A.B.C.D IP address to match
R1(config-router)#area 1 range 141.108.0.0 ? A.B.C.D IP mask for address
R1(config-router)#area 1 range 141.108.0.0 255.255.248.0
The ? tool is used to display the various options. The mask, 255.255.248.0,
encompasses the seven networks ranging from 141.108.0.0–141.108.7.0. You may ask yourself why you are not using 141.108.0.0 on R1 or subnet zero. With large IP networks, the network IP designer should always use all the address space available;
subnet zero is a perfect example.
To enable subnet zero, you must configure the global ip subnet-zero command on R1.
Example 8-40 enables the use of zero subnets on R1.
Example 8-40 Subnet Zero Enabling on R1
R1(config)#ip subnet-zero
R1(config-if)#interface loopback 6
R1(config-if)#ip address 141.108.0.1 255.255.255.0
Example 8-41 displays the summarization required on R2 to encompass the networks 141.108.8.0–141.108.15.255. (These networks reside in area 2.)
Example 8-41 Area Summary on R2
R2(config)#router ospf 1
R2(config-router)#area 2 range 141.108.8.0 255.255.248.0
Example 8-42 displays the summarization required on R3 to encompass the networks 141.108.16.0–141.108.23.255. (These networks reside in area 3.)
Example 8-42 Area Summary on R2
R3(config)#router ospf 1
R3(config-router)#area 3 range 141.108.16.0 255.255.248.0
Example 8-43 displays the OSPF IP routing table on R1. (Initially, when RIP was the primary routing algorithm, you had 17 RIP entries, as displayed in Example 8-21.)
Example 8-43 show ip route ospf on R1
R1#show ip route ospf
141.108.0.0/16 is variably subnetted, 13 subnets, 3 masks O 141.108.255.8/30 [110/1562] via 141.108.255.2, 00:04:57, Serial1/0
O IA 141.108.8.0/21 [110/791] via 141.108.255.2, 00:04:57, Serial1/0 O IA 141.108.16.0/21 [110/782] via 141.108.255.6, 00:01:13,
Serial1/1
R1 has 3 OSPF network entries as opposed to 17 using RIP.
Now, you can see why networks are converted from classful routing protocols, such as RIP, to classless protocols, such as OSPF. The migration in this scenario
demonstrates the powerful use of redistribution and what you should be aware of when configuring metrics. Before looking at another scenario, view the full working configurations of all three routers in Figure 8-4.
Example 8-44 displays R1's full working configuration.
Example 8-44 R1's Full Working Configuration
Hostname R1
!
enable password cisco
!
ip subnet-zero interface Loopback0
ip address 141.108.2.1 255.255.255.0
!
interface Loopback1
ip address 141.108.3.1 255.255.255.0
!
interface Loopback2
ip address 141.108.4.1 255.255.255.0
!
interface Loopback3
ip address 141.108.5.1 255.255.255.0
!
interface Loopback4
ip address 141.108.6.1 255.255.255.0
!
interface Loopback5
ip address 141.108.7.1 255.255.255.0
!
interface Loopback6
ip address 141.108.0.1 255.255.255.0
!
interface Ethernet0/0
ip address 141.108.1.1 255.255.255.0
!
interface Serial1/0
ip address 141.108.255.1 255.255.255.252 no ip mroute-cache
no fair-queue clockrate 128000
!
interface Serial1/1
ip address 141.108.255.5 255.255.255.252 clockrate 128000
!
router ospf 1
area 1 range 141.108.0.0 255.255.248.0 network 141.108.0.0 0.0.7.255 area 1 network 141.108.255.0 0.0.0.255 area 0
!
ip classless end
Example 8-45 displays R2's full working configuration.
Example 8-45 R2's Full Working Configuration
hostname R2
!
enable password cisco
!
ip subnet-zero no ip domain-lookup interface Loopback0
ip address 141.108.9.1 255.255.255.0
!
interface Loopback1
ip address 141.108.10.1 255.255.255.0
!
interface Loopback2
ip address 141.108.11.1 255.255.255.0
!
interface Loopback3
ip address 141.108.12.1 255.255.255.0
!
interface Loopback4
ip address 141.108.13.1 255.255.255.0
!
interface Loopback5
ip address 141.108.14.1 255.255.255.0
!
interface Loopback6
ip address 141.108.15.1 255.255.255.0
!
interface Ethernet0/0
ip address 141.108.8.1 255.255.255.0
!
interface TokenRing0/0 no ip address
shutdown
ring-speed 16
!
interface Serial1/0 bandwidth 128
ip address 141.108.255.2 255.255.255.252
!
interface Serial1/1
ip address 141.108.255.10 255.255.255.252
!
router ospf 1
area 2 range 141.108.8.0 255.255.248.0 network 141.108.8.0 0.0.7.255 area 2 network 141.108.255.0 0.0.0.255 area 0
!
ip classless
! end
Example 8-46 displays R3's full working configuration.
Example 8-46 R3's Full Working Configuration
hostname R3
!
enable password cisco
!
no ip domain-lookup
!
interface Loopback0
ip address 141.108.17.1 255.255.255.0
!
interface Loopback1
ip address 141.108.18.1 255.255.255.0
!
interface Loopback2
ip address 141.108.19.1 255.255.255.0
!
interface Loopback3
ip address 141.108.20.1 255.255.255.0
!
interface Loopback4
ip address 141.108.21.1 255.255.255.0
!
interface Loopback5
ip address 141.108.22.1 255.255.255.0
!
interface Loopback6
ip address 141.108.23.1 255.255.255.0
!
interface Ethernet0
ip address 141.108.16.1 255.255.255.0 media-type 10BaseT
!
interface Ethernet1 no ip address
!
interface Serial0
ip address 141.108.255.6 255.255.255.252 bandwidth 125
!
interface Serial1
ip address 141.108.255.9 255.255.255.252 bandwidth 125
clockrate 125000
!
router ospf 1
network 141.108.16.0 0.0.7.255 area 3 network 141.108.255.0 0.0.0.255 area 0 area 3 range 141.108.16.0 255.255.248.0
! end