Redistributing Between RIP and IGRP

Một phần của tài liệu CCNP practical studies routing (Trang 360 - 368)

In this scenario, you configure three routers running RIP and IGRP. Router R1 is running both RIP and IGRP, and you configure it for redistribution.

Figure 8-2 displays the three-router topology with the Router R1 running RIP and IGRP.

Figure 8-2. RIP/IGRP Redistribution

Figure 8-2 displays a simple scenario with the Class A network 9.0.0.0 subnetted with a Class C mask. Notice that R2 has the Class 10.1.1.0/24 network configured locally on the Ethernet interface.

Start by configuring the edge devices for IGRP on R3 and RIP on R2.

Example 8-1 displays the IP address configuration on R1 and the enabling of IGRP in AS 100.

Example 8-1 IP Address Configuration and Enabling IGRP on R3

R3(config)#interface ethernet 0

R3(config-if)#ip address 9.1.3.1 255.255.255.0 R3(config-if)#interface serial0

R3(config-if)#ip address 9.1.2.2 255.255.255.0 R3(config-if)#exit

R3(config)#router igrp 10

R3(config-router)#network 9.0.0.0

Notice, on R3, when enabling IGRP in AS 10, the network command used is network 9.0.0.0 because IGRP is classful and automatically summarizes at the Class A network boundary.

Example 8-2 configures R2 for IP addressing and enables RIP.

Example 8-2 IP Address Configuration and Enabling RIP

R2(config)#interface ethernet 0/0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 R2(config-if)#interface serial 1/0

R2(config-if)#ip address 9.1.1.2 255.255.255.0 R2(config)#router rip

R2(config-router)#network 9.0.0.0 R2(config-router)#network 10.0.0.0

R2 is running another classful IP routing protocol: RIP. Therefore, when defining networks under the RIP process, you need to identify only the major network boundary, in this case 9.0.0.0 and 10.0.0.0.

R2 is configured for RIP and IGRP, and hence, requires redistribution, and you must ensure the metrics are converted from RIP (hop count) to IGRP (composite metric).

Example 8-3 displays the IP address configuration on R1 along with enabling IGRP and RIP. No redistribution is configured at this time.

Example 8-3 Enable IP and RIP/IGRP on R1

R1(config)#interface S1/0

R1(config-if)#ip address 9.1.1.1 255.255.255.0 R1(config-if)#interface S1/1

R1(config-if)#ip address 9.1.2.1 255.255.255.0 R1(config-if)#exit

R1(config)#router rip

R1(config-router)#network 9.0.0.0 R1(config-router)#exit

R1(config)#router igrp 10

R1(config-router)#network 9.0.0.0

R1 is configured locally for the Class A subnet network 9.0.0.0 for both RIP and IGRP. Therefore, you must ensure that RIP updates are not sent to R3, which is running only IGRP, and ensure IGRP updates are not sent to R2, which is running only IGRP.

Example 8-4 configures passive interfaces to ensure that only RIP updates are sent to R2 and IGRP updates are sent to R3.

Example 8-4 Passive Interfaces on R1

R1(config)#router rip

!Ensure RIP updates are not sent to R3 R1(config-router)#passive-interface s1/1 R1(config-router)#router igrp 10

!Ensure IGRP updates are not sent to R2

R1(config-router)#passive-interface s1/0 Example 8-5 displays the IP routing table on R1.

Example 8-5 IP Routing Table on R1

R1#show ip route

9.0.0.0/24 is subnetted, 3 subnets

C 9.1.1.0 is directly connected, Serial1/0 C 9.1.2.0 is directly connected, Serial1/1

I 9.1.3.0 [100/80225] via 9.1.2.2, 00:00:31, Serial1/1 R 10.0.0.0/8 [120/1] via 9.1.1.2, 00:00:15, Serial1/0

Currently, the IP routing table on R1 displays network connectivity to R2 and R3. R1 has full IP connectivity to R2 and R3. Also, notice that R1 assumes that the entire Class A network 10.0.0.0/8 is reachable through R2 because R1 does not have any locally connected routes in the 10.0.0.0 network.

Example 8-6 displays the IP routing table on R2.

Example 8-6 show ip route on R2

R2#show ip route

9.0.0.0/24 is subnetted, 2 subnets

C 9.1.1.0 is directly connected, Serial1/0

R 9.1.2.0 [120/1] via 9.1.1.1, 00:00:27, Serial1/0 10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Ethernet0/0

The routing table on R2 in Example 8-6 displays no network connectivity to the LAN segment 9.1.3.0/24 because you have yet to configure redistribution on R1.

To configure redistribution, you must perform the following tasks on R1:

Step 1. Use the redistribute command on R1 to specify the routes to be redistributed.

Step 2. Specify the metric to be assigned to any redistributed routes.

Example 8-7 displays the redistribution command on R1. You set the metric for redistributing IGRP to RIP to a hop count of 1.

Example 8-7 Redistributing IGRP into RIP on R1

R1(config)#router rip

R1(config-router)#redistribute igrp 10 metric 1

At this stage, you haven't configured redistribution from RIP into IGRP so that R3 has full connectivity to R2. Example 8-8 displays redistribution from RIP to IGRP. The ? tool is used to displays IGRP metrics. Typically, the metrics used match those on the link from R1 to R2 (using the show interfaces serial 1/0 command and using the values output from this display).

Example 8-8 Redistribution from RIP to IGRP on R1

R1(config)#router igrp 10

R1(config-router)#redistribute rip ?

metric Metric for redistributed routes route-map Route map reference

<cr>

R1(config-router)#redistribute rip metric ?

<1-4294967295> Bandwidth metric in Kbits per second R1(config-router)#redistribute rip metric 128 ?

<0-4294967295> IGRP delay metric, in 10 microsecond units R1(config-router)#redistribute rip metric 128 20000 ?

<0-255> IGRP reliability metric where 255 is 100% reliable R1(config-router)#redistribute rip metric 128 20000 255 ?

<1-255> IGRP Effective bandwidth metric (Loading) where 255 is 100%

loaded

R1(config-router)#redistribute rip metric 128 20000 255 1 ? <1-4294967295> IGRP MTU of the path

R1(config-router)#redistribute rip metric 128 20000 255 1 1500

Examine the IP routing tables on R2 and R3 to ensure IP connectivity by pinging the remote network 9.1.3.1 as displayed in Example 8-9.

Example 8-9 IP Routing Table and Ping Request to 9.1.3.1/24 on R2

R2#show ip route

9.0.0.0/24 is subnetted, 3 subnets

C 9.1.1.0 is directly connected, Serial1/0

R 9.1.2.0 [120/1] via 9.1.1.1, 00:00:09, Serial1/0 R 9.1.3.0 [120/1] via 9.1.1.1, 00:00:09, Serial1/0 10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Ethernet0/0 R2#ping 9.1.3.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 9.1.3.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Example 8-9 displays the remote network 9.1.3.0 reachable through the next hop address 9.1.1.1, and the metric is 1, as defined by the redistribution command in Example 8-7. A ping to the remote address 10.1.1.1/24 on R3 is successful.

Example 8-10 displays the IP routing table on R3, as well as a ping request and reply to the remote network 9.1.3.1/24.

Example 8-10 IP Routing Table and Ping Request on R3

R3#show ip route

9.0.0.0/24 is subnetted, 3 subnets

I 9.1.1.0 [100/84000] via 9.1.2.1, 00:00:58, Serial0 C 9.1.2.0 is directly connected, Serial0

C 9.1.3.0 is directly connected, Ethernet0

I 10.0.0.0/8 [100/102000] via 9.1.2.1, 00:00:58, Serial0 R3#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms A ping to the remote address 10.1.1.1/24 on R3 is successful because the remote network 10.0.0.0/8 is reachable through the next hop address 9.1.2.1 or through R1.

Next, you configure a new subnet on R3 to make the networks a little more complex.

Configure the address 10.1.2.1 as a loopback interface on R3 using a 24-bit subnet mask, and enable IGRP on R3 to advertise the 10.0.0.0 network.

Example 8-11 displays the loopback creation on R3 and the enabling of IGRP to advertise the loopback under IGRP.

Example 8-11 Loopback Creation on R3

R3(config-if)#interface loopback 0

R3(config-if)#ip address 10.1.2.1 255.255.255.0 R3(config-if)#router igrp 10

R3(config-router)#network 10.0.0.0

R3 does not advertise the 10.0.0.0 network to R1. Remember from Example 8-5, R1 had seen the 10.0.0.0/8 network advertised through RIP with an AD of 120 through R2 (RIP). Example 8-12 displays the IP routing table on R1 after an IGRP update is sent from R3 to R1.

Example 8-12 show ip route on R1

R1#show ip route

9.0.0.0/24 is subnetted, 3 subnets

C 9.1.1.0 is directly connected, Serial1/0 C 9.1.2.0 is directly connected, Serial1/1

I 9.1.3.0 [100/80225] via 9.1.2.2, 00:00:23, Serial1/1 I 10.0.0.0/8 [100/80625] via 9.1.2.2, 00:00:23, Serial1/1 R1 changes the path to 10.0.0.0 through R3 because the AD of IGRP is 100,

compared to RIP, which is 120. In effect, R1 sends all traffic for the 10.0.0.0 network through R3. Example 8-13 displays a ping request to the IP address 10.1.1.1 (R3's Ethernet interface) and 10.1.2.1 (R3's loopback interface).

Example 8-13 Ping Request on R1

R1#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

...

Success rate is 0 percent (0/5) R1#ping 10.1.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

All packets are sent to R3 because the IP routing table selects IGRP as the preferred path to all networks in the Class A range 10.0.0.0. Of course, this is not the desired solution because you have 10.0.0.0 networks configured on R2 and R3. There are a number of different solutions to this, but in this case, configure R1 to reject any networks in the 10.0.0.0 range because the only trusted information for this Class A network is from the RIP domain.

NOTE

Another method to overcome network connectivity problems is to configure static routes on R1 or enable an interface in the 10.0.0.0/24 range on R1.

Example 8-14 configures a distribution list on R1, rejects all networks in the 10.0.0.0 range, and accepts all other networks.

Example 8-14 Distribution List on R1

R1(config)#router igrp 10

R1(config-router)#distribute-list 1 in R1(config-router)#exit

R1(config)#access-list 1 deny 10.0.0.0 R1(config)#access-list 1 permit any

The distribute-list command, when configured on R1, does not permit the 10.0.0.0 network, as displayed in Example 8-14. Therefore, when 10.0.0.0 is advertised by R3 to R1, R1 does not accept the 10.0.0.0 network.

Example 8-15 confirms the installation on the RIP-discovered route through R2.

Example 8-15 show ip route on R1

R1#sh ip route

9.0.0.0/24 is subnetted, 3 subnets

C 9.1.1.0 is directly connected, Serial1/0 C 9.1.2.0 is directly connected, Serial1/1

I 9.1.3.0 [100/80225] via 9.1.2.2, 00:00:07, Serial1/1 R 10.0.0.0/8 [120/1] via 9.1.1.2, 00:00:07, Serial1/0

Any form of redistribution requires careful filtering. At this point, R1 has lost

connectivity to the 10.1.2.0/24. To solve this problem, configure a static route on R1 with a more specific destination pointing to R3.

Example 8-16 displays the static route configuration on R1.

Example 8-16 Static IP Route on R1

R1(config)#ip route 10.1.2.0 255.255.255.0 Serial1/1

Cisco IOS routers, because the AD of static routes is 1 and is lower then RIP at 120, send traffic for the more specific route through Serial 1/1 for hosts in the range 10.1.2.1–254/24.

Example 8-17 displays the IP routing table on R1 and a successful ping request to 10.1.1.1 (to R2) and 10.1.2.1 (to R3)

Example 8-17 show ip route and Ping Request on R1

R1#show ip ro

9.0.0.0/24 is subnetted, 3 subnets

C 9.1.1.0 is directly connected, Serial1/0 C 9.1.2.0 is directly connected, Serial1/1

I 9.1.3.0 [100/80225] via 9.1.2.2, 00:00:54, Serial1/1 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks S 10.1.2.0/24 is directly connected, Serial1/1

R 10.0.0.0/8 [120/1] via 9.1.1.2, 00:00:36, Serial1/0 R1#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms R1#ping 10.1.2.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms In a simple three router network, you can determine that with even a few networks, redistribution causes routers to misinterpret information based on network

configuration and classful behavior of routing protocols, such as RIP and IGRP. In the scenarios that follow, you apply route maps instead of distribution lists to learn to use other filtering methods. You also use the passive-interface command to ensure that a network running route redistribution is configured as efficiently as possible.

Example 8-18 displays R1's full working configuration.

Example 8-18 R1's Full Working Configuration

hostname R1

!

enable password cisco

!

interface Serial1/0

ip address 9.1.1.1 255.255.255.0 clockrate 128000

!

interface Serial1/1

ip address 9.1.2.1 255.255.255.0 clockrate 128000

!

router rip

redistribute igrp 10 metric 1 passive-interface Serial1/1 network 9.0.0.0

!

router igrp 10

redistribute rip metric 128 20000 255 1 1500 passive-interface Serial1/0

network 9.0.0.0

distribute-list 1 in

ip route 10.1.2.0 255.255.255.0 Serial1/1

!

access-list 1 deny 10.0.0.0 access-list 1 permit any line con 0

line aux 0 line vty 0 4 end

Example 8-19 displays R2's full working configuration.

Example 8-19 R2's Full Working Configuration

hostname R2

!

enable password cisco

!

ip subnet-zero no ip domain-lookup

!

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

!

interface Serial1/0 bandwidth 128

ip address 9.1.1.2 255.255.255.0

!

router rip

network 9.0.0.0 network 10.0.0.0 line con 0

line aux 0 line vty 0 4 end

Example 8-20 displays R3's full working configuration.

Example 8-20 R3's Full Working Configuration

hostname R3

!

enable password cisco

!

interface Loopback0

ip address 10.1.2.1 255.255.255.0

!

interface Ethernet0

ip address 9.1.3.1 255.255.255.0 interface Serial0

ip address 9.1.2.2 255.255.255.0 bandwidth 125

router igrp 10 network 9.0.0.0 network 10.0.0.0

!

no ip classless line con 0 line aux 0 line vty 0 4

! end

Một phần của tài liệu CCNP practical studies routing (Trang 360 - 368)

Tải bản đầy đủ (PDF)

(498 trang)